Excel Frage


Hallo Liebe Community, ich möchte bei Excel was realisieren wo ich nicht genau weiß wie, bzw. wie ich das in Google suchen kann.

Ich möchte in einen Tilgungsrechner die Prozentzahl an Tilgung entweder per % eingeben oder in Euro eingeben können.

Soll dann in etwa so aussehen.

Wenn "Eingegebene Zahl kleiner wie 20" dann sehe den Wert als %
Wenn "Eingegebene Zahl größer wie 20" dann "eingegebener Wert mal 12 geteilt durch Darlehenssumme x 100

Dieses Wenn dann würde kein Problem darstellen, aber wie mache ich eine Formel in eine Zelle?


Zitat (pokiqu @ 10.07.2018 09:54:38)
Dieses Wenn dann würde kein Problem darstellen, aber wie mache ich eine Formel in eine Zelle?

Zum Beispiel so:
=WENN(ODER(C7=1;C7=12;C7=13);"Vorsicht";WENN(ODER(C7=7;C7=18);"geringe Vorsicht";WENN(ODER(C7=2;C7=3;C7=4;C7=5;C7=6;C7=8;C7=9;C7=10;C7=11);"+";WENN(ODER(C7=14;C7=15;C7=16;C7=17;C7=19;C7=20;C7=21;C7=22;C7=23);"-";""))))

Ist die Formel für eine Zelle für meinen Biorhythmus. Muß ich vor über 20 Jahren mal lernen.

Zitat (viertelvorsieben @ 10.07.2018 11:17:36)
=WENN(ODER(C7=1;C7=12;C7=13);"Vorsicht";WENN(ODER(C7=7;C7=18);"geringe Vorsicht";WENN(ODER(C7=2;C7=3;C7=4;C7=5;C7=6;C7=8;C7=9;C7=10;C7=11);"+";WENN(ODER(C7=14;C7=15;C7=16;C7=17;C7=19;C7=20;C7=21;C7=22;C7=23);"-";""))))

Igitt :-)

Bei der Frage würde ich erst einmal darauf achten, daß die Eingabewerte und die Ergebnisse der Formel in zwei getrennten Spalten erscheinen, also z.B. C und D - sonst gehts wohl nur mit Programmierung. Für einen vernünftigen Druck kann dann für C die Spaltenbreite auf 0 gesetzt werden.
Die Formel in Zelle D10 müsste dann (ungeprüft "nur zur Verrechnung"..) etwa so lauten (Darlehen in $B$2):
=wenn(c10<20;c10;c10*12/(100*$B$2)). Die Ergebnisspalte kannst Du dann als Prozent formatieren.